Requirements Environment For Installing Oracle11gR2 On RHEL 5/OEL 5 (x86_64)


Memory Requirements (Swap)

The following are the memory requirements for installing Oracle Database 11g Release 2 (11.2):

  • At least 4 GB of RAM
  • Swap require :
Available RAM Swap Space Required
Between 4 GB and 8 GB 2 times the size of RAM
Between 8 GB and 32 GB 1.5 times the size of RAM
More than 32 GB 32 GB

Disk Space Requirements

The following are the disk space requirements for installing Oracle Database 11g Release 2 (11.2):

  • At least 1 GB of disk space in the /tmp directory
  • The following tables describe the disk space requirements for software files, and data files for each installation type on Linux x86-64:

Installation Type Requirement for Software Files (GB)
Enterprise Edition 4.35
Standard Edition 3.73

Kernel Requirements

The following are the kernel requirements for Oracle Database 11g Release 2 (11.2):

  For Asianux 3, Oracle Linux 5, and Red Hat Enterprise Linux 5:

2.6.18 or later

4.3 Package Requirements

  The following or later version of packages for Asianux 3, Oracle Linux 5, and Red Hat Enterprise Linux 5 should be installed:

binutils-2.17.50.0.6

compat-libstdc++-33-3.2.3

compat-libstdc++-33-3.2.3 (32 bit)

elfutils-libelf-0.125

elfutils-libelf-devel-0.125

gcc-4.1.2

gcc-c++-4.1.2

glibc-2.5-24

glibc-2.5-24 (32 bit)

glibc-common-2.5

glibc-devel-2.5

glibc-devel-2.5 (32 bit)

glibc-headers-2.5

ksh-20060214

libaio-0.3.106

libaio-0.3.106 (32 bit)

libaio-devel-0.3.106

libaio-devel-0.3.106 (32 bit)

libgcc-4.1.2

libgcc-4.1.2 (32 bit)

libstdc++-4.1.2

libstdc++-4.1.2 (32 bit)

libstdc++-devel 4.1.2

make-3.81

numactl-devel-0.9.8.x86_64

sysstat-7.0.2

4.5 Additional Software Requirements

4.5.1 Oracle ODBC Drivers

  On Asianux Server 3, Oracle Linux 5, and Red Hat Enterprise Linux 5:

  • unixODBC-2.2.11 (32-bit) or later
  • unixODBC-devel-2.2.11 (64-bit) or later
  • unixODBC-2.2.11 (64-bit) or later

4.5.2 Oracle JDBC/OCI Drivers

Use JDK 6 (Java SE Development Kit 1.6.0_21) or JDK 5 (1.5.0_24) with the JNDI extension with the Oracle Java Database Connectivity and Oracle Call Interface drivers. However, these are not mandatory for the database installation. Note that IBM JDK 1.5 is installed with this release.

4.5.3 Linux-PAM Library

Install the latest Linux-PAM (Pluggable Authentication Modules for Linux) library to enable the system administrator to choose how applications authenticate users.

4.5.4 Oracle Messaging Gateway

Oracle Messaging Gateway supports the integration of Oracle Streams Advanced Queuing (AQ) with the following software:

  • IBM WebSphere MQ V6.0, client and server, with corrective service diskette 5 (CSD05) or later:
  • TIBCO Rendezvous 7.3
·         MQSeriesClient
·         MQSeriesServer
·         MQSeriesRuntime

5.1 Port Open

  • SSH
  • VNC

6. Mounting point for Oracle binary, Oradata, Flash Recovery Area

[ini mungkin bisa ditanyakan kepada user maunya bagaimana ]

Biasanya :

/oraclebase/oracle      = 40 G

/oradata                              = 300 G

/orarecovery                   = 300 G

/source                                = 20 G

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s